vladg/sound

"Molot" and "Limiter №6" plugins page (and Tokyo Dawn Labs stuff too)

Category Archives: RTAS

Molot 0.3.1 with AU version will be available soon

Check this screenshot:

You can see that parameter values are shown and can be edited.

PS. Also I checked VST version with RTAS wrapper. And it’s OK!

PPS. Also with 64-bit support of course!

 

 

Advertisements

Limiter №6 v1.0.1 last preview

Limiter №6 v1.0.1 has completed. I want to make last checks until monday and then update “official” links on downloads page. EDIT: updated

Windows VST 32-bit and 64-bit:

Limiter6-v101-gui1.zip / Limiter6-v101-gui2.zip

Mac OS X VST 32-bit and 64-bit:

Limiter6-v101-gui1.dmg / Limiter6-v101-gui2.dmg

What’s new:

– Mac VST 64-bit support;
– Fixed CPU-related GUI issues;
– Support of DirectX acceleration for Vista/Seven (less CPU for graphics).

PS. Also I sucessfully checked this version with RTAS wrapper.

PPS. Sound engine and functionality was not changed. The PDF manual is still the same:

Limiter6-manual-en.pdf / Limiter6-manual-ru.pdf / Limiter6-manual-jp.pdf

VSTGUI 4.0.1 and VST RTAS Wrapper

Developers only information. I did VSTGUI 3.5 -> VSTGUI 4.0.1 port for latest Limiter №6 version to support 64-bit Mac and I (again) have problems with VST RTAS Wrapper on Mac (with Molot I almost solved them in 0.2.168c version if you remember) and Limiter №6 v1.0 worked fine with this wrapper most of the time.

Read more of this post

Molot 0.2.168c works in Pro Tools via VST to RTAS adapter!

Today I killed a half of day to make it works on Mac with Pro Tools (anyway it was raining). It worked! I was happy and decided to film it on mobile phone. But… then happen what in Russia calls “General’s effect” – it means in army when the general has come all military devices become unstable (e.g. don’t work).

See the video!

I tried next several hours to reproduce this crash but didn’t succeeded (let me remind you I don’t own Mac and can’t do this each day).  That’s means this version of plugin can’t be used in real Pro Tools projects. Let’s say it’s beta version.

But you can help me! Version 0.2.168c for Mac is available on Downloads page.

If you can reproduce this crash please press “Report” then “Information”, copy all text in the window and send me to vl-g AT yandex DOT ru. Let’s make it stable!

Thank you!

EDIT2: Jay, thanks for the dump!

EDIT3 (it’s february 2013 and Molot 0.3.1 now works with this wrapper)

Read more of this post